使用rbenv的安装ruby和rails

作者:周星 发布:2017-10-07

对于到底是使用rvm还是rbenv,一直处于争论之中,经过体验和对比,我最终放弃了rvm,选择了rbenv。

这篇简单介绍 rbenv 的安装和使用. 如果可以请直接看作者的文档: https://github.com/sstephenson/rbenv

rbenv 用来管理多个版本的 ruby 在用户目录的安装和使用, 和 rvm 二选一使用. 具体区别 rbenv 的文档里有说明, 社区里也有讨论.

系统需求

  • OSX: 请找一个网好的地方, 从 app store 里下载 xcode.app, 安装完成后运行, 在设置中的 Downloads 里安装 Command Line Tools.

  • Linux: 请安装开发环境 (编译链接工具和 ruby 的依赖), 如果只要 jruby 有 jre 就可以了.

安装Linux开发环境(以Ubuntu为例):

sudo apt-get update
sudo apt-get install -y build-essential openssl curl libcurl3-dev libreadline6 libreadline6-dev git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libxml2-dev libxslt-dev autoconf automake libtool imagemagick libmagickwand-dev libpcre3-dev libsqlite3-dev

推荐手动安装过程. (不用 zsh 的童鞋注意替换成自己的 shell 配置文件)

git clone git://github.com/sstephenson/rbenv.git ~/.rbenv
# 用来编译安装 ruby
git clone git://github.com/sstephenson/ruby-build.git ~/.rbenv/plugins/ruby-build
# 用来管理 gemset, 可选, 因为有 bundler 也没什么必要
git clone git://github.com/jamis/rbenv-gemset.git  ~/.rbenv/plugins/rbenv-gemset
# 通过 gem 命令安装完 gem 后无需手动输入 rbenv rehash 命令, 推荐
git clone git://github.com/sstephenson/rbenv-gem-rehash.git ~/.rbenv/plugins/rbenv-gem-rehash
# 通过 rbenv update 命令来更新 rbenv 以及所有插件, 推荐
git clone https://github.com/rkh/rbenv-update.git ~/.rbenv/plugins/rbenv-update

然后把下面的代码放到 ~/.bash_profile 里

export PATH="$HOME/.rbenv/bin:$PATH"
eval "$(rbenv init -)"

注意 Unubtu请放到 ~/.bashrc 里, zsh用户是 ~/.zshrc

然后重开一个终端就可以执行 rbenv 了.

安装 ruby

rbenv install --list  # 列出所有 ruby 版本
rbenv install 1.9.3-p392     # 安装 1.9.3-p392
rbenv install jruby-1.7.3    # 安装 jruby-1.7.3

执行一下 which ruby 和 which gem,发现他们都安装在了 .rbenv 目录下

~ ➤ which ruby/Users/username/.rbenv/shims/ruby
~ ➤ which gem
/Users/username/.rbenv/shims/gem

更新可安装ruby版本列表

cd ~/.rbenv/plugins/ruby-build
git pull

列出版本

rbenv versions               # 列出安装的版本
rbenv version                # 列出正在使用的版本

设置版本

rbenv global 1.9.3-p392      # 默认使用 1.9.3-p392
rbenv shell 1.9.3-p392       # 当前的 shell 使用 1.9.3-p392, 会设置一个 `RBENV_VERSION` 环境变量
rbenv local jruby-1.7.3      # 当前目录使用 jruby-1.7.3, 会生成一个 `.rbenv-version` 文件

解决 MacOSX 下编译 Ruby 无法在 irb 中输入中文的方法

安装 homebrew 的 readline,再进入源码目录,重新编译安装 readline.bundle

brew install readline
brew link readline
cd src/ruby-1.9.3-p392/ext/readline
ruby extconf.rb --with-readline-dir=$(brew --prefix readline)
make install

rbenv 下的解决办法

brew install readline
CONFIGURE_OPTS="--disable-install-doc --with-readline-dir=$(brew --prefix readline)" rbenv install 1.9.3-p392

有关 ruby-2.0.0-p0 在 OS X 10.7+ 上的问题,参见:https://github.com/sstephenson/ruby-build/wiki

其他

rbenv rehash                 # 每当切换 ruby 版本和执行 bundle install 之后必须执行这个命令
rbenv which irb              # 列出 irb 这个命令的完整路径
rbenv whence irb             # 列出包含 irb 这个命令的版本

rbenv 下使用 gemset

简介

rvm 中最方便的就是 gemset。实际上,rbenv 通过插件也可以使用 gemset

安装

MacOS 下使用 brew 的话,一个命令就搞定

brew install rbenv-gemset

创建一个 gemset

rbenv gemset create 1.9.3-p392 ruby-china
                       参数 1       参数 2
  • 以上命令中,参数 1 是已安装的 ruby 版本,参数 2 是 gemset 的名字

具体使用方法

  1. 在项目的根目录下,把想要使用的 gemset 名字放到 .rbenv-gemsets 文件中即可。有 .rbenv-gemsets 文件的情况下执行 bundle 命令就是对设置好的 gemset 进行操作

    echo ruby-china > .rbenv-gemsets
    
  2. 当前目录下没有 .rbenv-gemsets 文件的情况下,执行 bundle 命令(没有指定 --path 参数的情况)时,是对当前版本的 ruby 版本的 gemset 。也就相当于 rvm 中 global gemset 的作用了

参考

下面是 Rails 的安装方法

先安装 bundler,bundler 用来帮我们管理依赖的 gems

gem install bundler

查看一下 bundler 是否安装在了 .rbenv 目录

~ ➤ which bundler
/Users/username/.rbenv/shims/bundler

然后通过 gem 安装 Rails 即可

gem install rails

支付宝扫码赞助博主


评论(1)

ev

ev第1楼

try rbenv-installer

2014-05-01 09:15:33